Все записи автора Заярный Андрей Александрович

Владелец сайта

Задача 25

Пример решения задачи №25 из нового ЕГЭ по информатике

Это довольно простая задача, которая проверяет основные навыки программирование, а именно умение находить делители числа, организовывать циклы, составлять подпрограммы.

Пример задачи

Напишите программу, которая ищет среди целых чисел, принадлежащих числовому отрезку [120115; 120200],
число, имеющее максимальное количество различных натуральных делителей, если таких чисел несколько — найдите максимальное из них. Выведите на экран количество делителей такого числа и само число.
Например, в диапазоне [80; 90] максимальное количество различных натуральных делителей имеет число 90,
поэтому для этого диапазона вывод на экране должна содержать следующие значения:
12 90

Ниже я выкладываю хорошо закомментированный код на Python, в котором не составит труда разобраться. Для лучшего понимания, скопируйте код программы в какой-нибудь редактор (Nodepad++, Блокнот) или в систему программирования (PyCharm, Visual Studio).

#Подсчитываем количество делителей числа
def Del(n):
    #число 1 рассматриваем отдельно, так как у него всего один делитель
    if n==1:
        return 1
    #у остальных чисел делителей как минимум 2 (1 и оно само)
    k=2
    #подсчитываем делители числа начиная перебирать числа 2 до n//2
    #например для числа 10 мы будем перебирать числа от 2 до 5
    for i in range(2,n//2+1):# +1 потому что в Python range перебирает числа до n-1
        if (n%i==0):#если число n делится на i без остатка,
            k+=1#то увеличиваем количество делителей на 1
    return k#возвращаем количество делителей числа

#решаем задачу
maxDel=Del(120115)#максимальное количество делитей
max=120115#число
for i in range(120116,120201):#перебираем числа из заданного диапазона не забывая прибавить 1 к последнему числу
    k=Del(i)#считаем количество делителей очередного числа
    if k>=maxDel:#если количество делителей очередного числа больше чем найденное ранее количество делителей
        maxDel=k#запоминаем количество делителей
        max=i#запоминаем число
print(maxDel,max)#выводим результат на экран

Для закрепления, решите следующие задачи используя условие и решение задачи данной выше:

  1. Найдите число, имеющее минимальное количество различных натуральных делителей
  2. Найдите число, имеющее максимальную сумму различных натуральных делителей
  3. Найдите максимальное простое число
  4. Найдите минимальное простое число

Демоверсия по информатике ЕГЭ 2021

Уже довольно давно появились демонстрационные варианты по ЕГЭ 2021. Ниже ссылка на вариант по информатике. Так же по ссылке вы можете найти тренажер по информатике и посмотреть как будет проходить тест в 2021 году. К сожалению, тренажер не показывает итоговый результат.

Ссылка: https://4ege.ru/informatika/60050-demoversija-po-informatike-ege-2021.html

Президент Хорватии нашла истоки коррупции в традиции списывать контрольные

Выступая на пресс-конференции в Загребе, как сообщает news.mail.ru, президент Хорватии Колинда Грабар-Китарович, призвала искать истоки коррупции в школьном возрасте. По ее мнению, среди школьников идет героизация тех, кто может обмануть систему и, например, списать на контрольной.

Источник

Ссылка на опрос

С 2020 года ЕГЭ по информатике будут сдавать на компьютере

Единый государственный экзамен по информатике будет проходить на компьютерах уже с 2020 года (нынешний 11 класс выдыхает, а вот 10 уже сосредотачивается, ВСЕГО 1,5 года до экзаменов!!! ). Новая модель проведения сейчас дорабатывается, а ее апробация прошла осенью 2018 года в 35 регионах России. Смысл новой модели состоит в том, что все задания выпускники будут выполнять при помощи компьютеров и с применением различных языков программирования и программного обеспечения. Напомню, сейчас экзамен проходит по аналогии с остальными итоговыми испытаниями – с использованием бумажных бланков КИМ ЕГЭ. По словам экспертов, вполне естественно, что школьники будут выполнять задания на компьютерах, ведь экзамен в основном состоит из заданий по программированию. Кроме того, ЕГЭ по информатике будут проверять без привлечения региональных экспертов, ведь теперь возможна автоматизированная проверка ответов. Особенно удобно это для проверки заданий, которые предполагают написание выпускниками программ: компьютер сможет их протестировать и проверить на работоспособность. В 2019 году модель еще раз апробируют, а с 2020 года абсолютно все выпускники, выбравшие эту дисциплину, будут сдавать итоговый экзамен только в компьютерной форме. ЕГЭ по информатике необходимо тем, кто планирует поступать в российские вузы на специальности, связанные с IT-технологиями. Этот экзамен нужен тем, кто хочет стать программистом, разработчиком, специалистом по информационным технологиям. Кстати, эта профессия в последнее время входит в ТОП самых востребованных в России и хорошо оплачивается. Однако, будьте внимательны, так как некоторые вузы в качестве вступительных испытаний на такие специальности принимают не ЕГЭ по информатике, а математике и физике. Внимательно изучайте перечни вступительных испытаний в конкретном вузе. Что же касается девятых классов, то 2020 году их тоже ожидают изменения. Как и в прошлом, так и в этом году форма сдачи экзамена остается на компьютере, вот только задания изменятся... На сайте fipi.ru можно ознакомиться с перспективными моделями ГИА-9 для 2020 года. Ничего сложного, но вот рандомный выбор и простота, в которую так верят ученики, не утруждающие себя изучением предметов, больше не работает. Теперь, чтобы сдать успешно экзамен, придется готовиться. И большая часть знаний закладывается уже в 7 и 8 классе (Привет тем, кто надеется подготовиться к экзамену за 2 недели ). Также в экзамене разработчики предполагают оценивать больше практических навыков в работе за компьютером, а именно составление презентаций и работа с форматированием текстового файла.

© Ссылка на источник: https://gym491uv.mskobr.ru/elektronnye_servisy/blog/makeeva_kseniya_anatol_evna/s_2020_goda_eg_po_informatike_budut_sdavat_na_komp_yutere/

Утверждены «Рекомендации по оцениванию ОГЭ 2019 года»

Утверждены «Рекомендации по оцениванию ОГЭ 2019 года»

Рособрнадзор утвердил минимальные баллы, необходимые для прохождения итоговой аттестации в девятых классах, а также для поступления в профильные десятые классы. В сообщении отмечается, что окончательно решение по баллам на ОГЭ 2019 года будут принимать органы исполнительной власти каждого субъекта РФ.

источник

Конституционный суд запретил призывать в армию совершеннолетних старшеклассников

Конституционный суд России постановил, что отсрочка от армии для совершеннолетних учеников школы не должна засчитываться как первая. Об этом говорится на сайте суда.

Причиной решения суда стало дело жителя Мордовии Павла Спиридонова, которого попытались забрать в армию из-за того, что он, по мнению военкоматов, уже потратил две отсрочки, полагающиеся по закону. Одну — в школе, когда ему исполнилось 18 лет, вторую — во время обучения в Мордовском университете. При этом он хотел поступить в магистратуру, но ему бы пришлось идти в армию.

Спиридонов решил, что подобная версия закона ставит его в неравные условия с теми, кому 18 лет исполняется уже после окончания школы. «Гарантируя право на образование и закрепляя конституционную обязанность гражданина РФ по защите Отечества, федеральный законодатель предусмотрел в качестве одного из основных академических прав обучающихся отсрочку от призыва на военную службу», — говорится в сообщении суда.

Решение 27(C4) задачи январского пробника 2018 года

Дан набор из N целых положительных чисел. Из этих чисел формируются все возможные пары (парой считаются два элемента, которые находятся на разных местах в наборе, порядок чисел в паре не учитывается), в каждой паре
вычисляется сумма элементов. Необходимо определить количество пар, для которых полученная сумма делится на 8.
Напишите эффективную по времени и по памяти программу для решения этой задачи.
Программа считается эффективной по времени, если при увеличении количества исходных чисел N в k раз время работы программы увеличивается не более чем в k раз.
Программа считается эффективной по памяти, если память, необходимая для хранения всех переменных программы, не превышает одного килобайта и не увеличивается с ростом N.
Максимальная оценка за правильную (не содержащую синтаксических ошибок и дающую правильный ответ при любых допустимых входных данных) программу, эффективную по времени и по памяти, – 4 балла.
Максимальная оценка за правильную программу, эффективную только по времени или только по памяти, – 3 балла.
Максимальная оценка за правильную программу, не удовлетворяющую требованиям эффективности, – 2 балла.
Вы можете сдать одну или две программы решения задачи. Если Вы сдадите две программы, каждая из них будет оцениваться независимо от другой,
итоговой станет бо́льшая из двух оценок.
Перед текстом программы кратко опишите алгоритм решения. Укажите использованный язык программирования и его версию.
Описание входных и выходных данных
В первой строке входных данных задаётся количество чисел N (1 ≤ N ≤ 1000).
В каждой из последующих N строк записано одно натуральное число, не превышающее 10 000.
Пример входных данных:
5
1
5
7
11
1

Пример выходных данных для приведённого выше примера входных данных: 3
Из 5 чисел можно составить 10 пар. В данном случае у трёх пар сумма делится на 8: 1 + 7, 1 + 7 (в наборе две единицы, поэтому пару 1+7 можно составить двумя способами), 5 + 11

Решение:

var a: array[0..7] of Integer;
q,n,i,s,s0,s1,s2,s3,s4: Integer;

begin
  ReadLn(n);
  for i:=1 to N do begin
    ReadLn(q);
    a[q mod 8]:=a[q mod 8]+1;
  end;
  s0:=a[0]*(a[0]-1) div 2;
  s4:=a[4]*(a[4]-1) div 2;
  s1:=a[1]*a[7];
  s2:=a[2]*a[6];
  s3:=a[3]*a[5];
  s:=s0+s4+s1+s2+s3;
  WriteLn(s);
end.

Краткое объяснение

Идея решения заключается в использовании частотного массива для хранения остатков от делений введенных чисел. Подсле того, как частотный массив заполнен мы должны подсчитать сколько сочетаний может быть для различных чисел.
Например, если есть 2 числа, которые в остатке дают 1 и 2 числа которые в остатке дают 7, то каждое число, которое делится на 1, может образовать с 2 числами пару из тех, которые в остатке дают 7, то есть это их произведение.

Если же число делится на 8, то каждое число, которое делится на 8, может сочетать с другими числами, которые делятся на 8.
Например, у нас 4 числа, которые делятся на 8 (8, 16, 24, 32), тогда
1 число образует пару еще с 3 числами, 3
1 число образует пару еще с 2 числами, 2
1 число образует пару еще с одним числом. 1
То есть это арифметическая прогрессия от 1 до (4-1). То есть (1-(4-1)/2*3=4/2*3 или 4*3 div 2.

С числами, которые делятся на 4 та же ситуация что и с числами, которые делятся на 8.

Итог — это сумма всех сочетаний

Минобрнауки опубликовало проект расписания ЕГЭ-2018

На официальном сайте правительства размещен проект приказа «Об утверждении единого расписания и продолжительности проведения единого государственного экзамена по каждому учебному предмету, перечня средств обучения и воспитания, используемых при его проведении в 2018 году».

Письмо для родителей перед экзаменами

Это письмо родителям учеников написал директор сингапурской школы. Но как же хочется, чтобы его прочитали все родители во всех школах в мире.

«Дорогие родители. У ваших детей скоро начнутся экзамены. Знаю, что вы все очень сильно беспокоитесь, чтобы они сдали их хорошо.

Но, пожалуйста, помните: среди учеников на этом экзамене будет художник, которому нет нужды досконально понимать математику. Будет предприниматель, для которого не так важна история или английская литература. Музыкант, которому не понадобится химия. Спортсмен, для которого физкультура важнее физики.

Здорово, если ваш ребенок получит хорошие оценки. Но, пожалуйста, не лишайте их уверенности в себе и достоинства, если этого не произойдет.

Скажите им, что это нормально, что это просто экзамен. Они созданы для куда более значительных вещей в жизни. Скажите им, что какими бы не были их оценки, вы любите их и не будете их судить.

Пожалуйста, сделайте это — и просто наблюдайте, как затем они будут завоевывать мир. Один экзамен или плохая отметка не отберет у них мечты и талант.

И, пожалуйста, не считайте докторов и инженеров единственными счастливыми людьми на планете.

С наилучшими пожеланиями, директор школы»